GDSCODES (Коды ошибок Firebird)

Доступно в

DSQL, ISQL, PSQL

Описание

SQLCODEGDSCODEСообщение
101335544366LВыделенный буфер памяти меньше, чем требуется
100335544338LNo match for first value expression
100335544354LНеверное значение RDB$DB_KEY
100335544367LAttempted retrieval of more segments than exist
100335544374LAttempt to fetch past the last record in a record stream
-84335544554LTable/procedure has non-SQL security class defined
-84335544555LColumn has non-SQL security class defined
-84335544668LПроцедура не возвращает значений или столбцов
-103335544571LDatatype for constant unknown
-104335544343LInvalid request BLR at offset
-104335544390LBLR syntax error: expected at offset , encountered
-104335544425LКонтекст уже используется (BLR error)
-104335544426LКонтекст не определен (BLR error)
-104335544429LBad parameter number
-104335544440L
-104335544456LInvalid slice description language at offset
-104335544570LНеверная команда
-104335544579LВнутрення ошибка
-104335544590LOption specified more than once
-104335544591LUnknown transaction option
-104335544592LInvalid array reference
-104335544634LToken unknown—line , char
-104335544608LUnexpected end of command
-104335544612LToken unknown
-150335544360LAttempted update of read-only table
-150335544362LCannot update read-only view
-150335544446LNotupdatable
-150335544546LCannot define constraints on views
-151335544359LAttempted update of read-only column
-155335544658L is not a valid base table of the specified view
-157335544598LMust specify column name for view select expression
-158335544599LNumber of columns does not match select list
-162335544685LDbkey not available for multi-table views
-170335544512LParameter mismatch for procedure
-170335544619LExternal functions cannot have more thaniO parameters
-171335544439LFunction could not be matched
-171335544458LColumn not array or invalid dimensions (expected , encountered )
-171335544618LReturn mode by value not allowed for this datatype
-172335544438LFunction is not defined
-204335544463LGenerator is not defined
-204335544502LReference to invalid stream number
-204335544509LCHARACTER SET is not defined
-204335544511LProcedure is not defined
-204335544515LStatus code unknown
-204335544516LException not defined
-204335544532LName of Referential Constraint not defined in constraints table.
-204335544551LCould not find table/procedure for GRANT
-204335544568LImplementation of text subtype not located.
-204335544573LDatatype unknown
-204335544580LTable unknown
-204335544581LProcedure unknown
-204335544588LCOLLATION is not defined
-204335544589LCOLLATION is not valid for specified CHARACTER SET
-204335544595LTrigger unknown
-204335544620LAlias conflicts with an alias in the same statement
-204335544621LAlias conflicts with a procedure in the same statement
-204335544622LAlias conflicts with a table in the same statement
-204335544635LThere is no alias or table named at this scope leveL
-204335544636LThere is no index for table
-204335544640LInvalid use of CHARACTER SET ОГ COLLATE
-204335544662LBLOB SUB_TYPE is not defined
-205335544396LColumn is not defined in table
-205335544552LCould not find column for GRANT
-206335544578LColumn unknown
-206335544587LColumn is not a Blob
-206335544596LSubselect illegal in this context
-208335544617LInvalid ORDER BY clause
-219335544395LTable is not defined
-239335544691LCache length too smalL
-260335544690LCache redefined
-281335544637LTable is not referenced in plan
-282335544638L“Table is referenced more than once in plan; use aliases to distinguish”
-282335544643L“The table is referenced twice; use aliases to differentiate”
-282335544659L“Table is referenced twice in view; use an alias to distinguish”
-282335544660L“View has more than one base table; use aliases to distinguish”
-283335544639LTable is referenced in the plan but not the from list
-284335544642LIndex cannot be used in the specified plan
-291335544531LColumn used in a PRIMARY/UNIQUE constraint must be NOT NULL.
-292335544534LCannot update constraints (RDB$REF_CONSTRAINTS).
-293335544535LCannot update constraints (RDB$CHECK_CONSTRAINTS).
-294335544536LCannot delete CHECK constraint entry (RDB$CHECK_CONSTRAINTS)
-295335544545LCannot update constraints (RDB$RELATION_CONSTRAINTS).
-296335544547LInternal isc software consistency check (invalid RDB$CONSTRAINT_TYPE)
-297335544558LOperation violates CHECK constraint on view or table
-313335544669LCount of column list and variable list do not match
-314335544565LCannot transliterate character between character sets
-401335544647LInvalid comparison operator for find operation
-402335544368LAttempted invalid operation on a Blob
-402335544414LBlob and array datatypes are not supported for operation
-402335544427LData operation not supported
-406335544457LSubscript out of bounds
-407335544435LNull segment of UNIQUE KEY
-413335544334L“Conversion error from string """""
-413335544454LFilter not found to convert type to type
-501335544327LInvalid request handle
-501335544577LAttempt to reclose a closed cursor
-502335544574LDeclared cursor already exists
-502335544576LAttempt to reopen an open cursor
-504335544572LCursor unknown
-508335544348LNo current record for fetch operation
-510335544575LCursor not updatable
-518335544582LRequest unknown
-519335544688LThe PREPARE statement identifies a prepare statement with an open cursor
-530335544466L“Violation of FOREIGN KEY constraint: """""
-530335544597LCannot prepare a CREATE DATABASE/SCHEMA statement
-532335544469LTransaction marked invalid by I/O error
-551335544352LNo permission for access to
-552335544550LOnly the owner of a table can reassign ownership
-552335544553LUser does not have GRANT privileges for operation
-553335544529LCannot modify an existing user privilege
-595335544645LThe current position is on a crack
-596335544644LIllegal operation when at beginning of stream
-597335544632LPreceding file did not specify length, so must include starting page number
-598335544633LShadow number must be a positive integer
-599335544607LGen.c: node not supported
-600335544625LA node name is not permitted in a secondary, shadow, cache or log file name
-600335544680LSort error: corruption in data structure
-601335544646LФайл базы данных или указанный файл уже существует.
-604335544593LArray declared with too many dimensions
-604335544594LIllegal array dimension range
-605335544682LInappropriate self-reference of column
-607335544351LUnsuccessful metadata update
-607335544549LCannot modify or erase a system trigger
-607335544657LArray/Blob/DATE/TIIMESTAMP datatypes not allowed in arithmetic
-615335544475LLock on table conflicts with existing lock
-615335544476LRequested record lock conflicts with existing lock
-615335544507LRefresh range number already in use
-616335544530LCannot delete PRIMARY KEY being used in FOREIGN KEY definition.
-616335544539LCannot delete index used by an integrity constraint
-616335544540LCannot modify index used by an integrity constraint
-616335544541LCannot delete trigger used by a CHECK Constraint
-616335544543LCannot delete column being used in an integrity constraint.
-616335544630LThere are dependencies
-616335544674LLast column in a table cannot be deleted
-617335544542LCannot update trigger used by a CHECK Constraint
-617335544544LCannot rename column being used in an integrity constraint.
-618335544537LCannot delete index segment used by an integrity constraint
-618335544538LCannot update index segment used by an integrity constraint
-625335544347L“Validation error for column , value """""
-637335544664LDuplicate specification of not supported
-660335544533LNon-existent PRIMARY or UNIQUE KEY specified for FOREIGN KEY
-660335544628LCannot create index
-663335544624LSegment count of 0 defined for index
-663335544631LToo many keys defined for index
-663335544672LToo few key columns found for index (incorrect column name?)
-664335544434L“key size exceeds implementation restriction for index """""
-677335544445L extension error
-685335544465LInvalid Blob type for operation
-685335544670LAttempt to index Blob column in index
-685335544671LAttempt to index array column in index
-689335544403LPage is of wrong type (expected , found )
-689335544650LWrong page type
-690335544679LSegments not allowed in expression index
-691335544681LNew record size of bytes is too big
-692335544477LMaximum indexes per table () exceeded
-693335544663LToo many concurrent executions of the same request
-694335544684LCannot access column in view
-802335544321LArithmetic exception, numeric overflow, or string truncation
-803335544349L“Attempt to store duplicate value (visible to active transactions) in unique index """""
-803335544665L“Violation of PRIMARY or UNIQUE KEY constraint: """""
-804335544380LWrong number of arguments on calL
-804335544583LSQLDA missing or incorrect version, or incorrect number/type of variables
-804335544584LCount of columns not equal count of values
-804335544586LFunction unknown
-806335544600LOnly simple column names permitted for VIEW WITH CHECK OPTION
-807335544601LNo where clause for VIEW WITH CHECK OPTION
-808335544602LOnly one table allowed for VIEW WITH CHECK OPTION
-809335544603LDISTINCT, GROUP ОГ HAVING not permitted for VIEW WITH CHECK OPTION
-810335544605LNo subqueries permitted for VIEW WITH CHECK OPTION
-811335544652LMultiple rows in singleton select
-816335544651LExternal file could not be opened for output
-817335544361LAttempted update during read-only transaction
-817335544371LAttempted write to read-only Blob
-817335544444LOperation not supported
-820335544356LMetadata is obsolete
-820335544379L“Unsupported on-disk structure for file <sf™g>;found, support
-820335544437LWrong DYN version
-820335544467LMinor version too high found expected
-823335544473LInvalid bookmark handle
-824335544474LInvalid lock level
-825335544519LInvalid lock handle
-826335544585LInvalid statement handle
-827335544655LInvalid direction forfind operation
-828335544678LInvalid key position
-829335544616LInvalid column reference
-830335544615LColumn used with aggregate
-831335544548LAttempt to define a second PRIMARY KEY for the same table
-832335544604LFOREIGN KEY column count does not match PRIMARY KEY
-833335544606LExpression evaluation not supported
-834335544508LRefresh range number not found
-835335544649LBad checksum
-836335544517LException
-837335544518LRestart shared cache manager
-838335544560LDatabase shutdown in seconds
-839335544686Ljournal file wrong format
-840335544687LIntermediate journal file fulL
-841335544677LToo many versions
-842335544697LPrecision should be greater than 0
-842335544698LScalecannot be greater than precision
-842335544699LShort integer expected
-842335544700LLong integer expected
-842335544701LUnsigned short integer expected
-901335544322LInvalid database key
-901335544326LUnrecognized database parameter block
-901335544328LInvalid Blob handle
-901335544329LInvalid Blob ID
-901335544330LInvalid parameter in transaction parameter block
-901335544331LInvalid format for transaction parameter block
-901335544332LInvalid transaction handle (expecting explicit transaction start)
-901335544337LAttempt to start more than transactions
-901335544339LInformation type inappropriate for object specified
-901335544340LNo information of this type available for object specified
-901335544341LUnknown information item
-901335544342LAction cancelled by trigger () to preserve data integrity
-901335544345LLock conflict on no wait transaction
-901335544350LProgram attempted to exit without finishing database
-901335544353LTransaction is not in limbo
-901335544355LBlob was not closed
-901335544357LCannot disconnect database with open transactions ( active)
-901335544358LMessage length error (encountered , expected )
-901335544363LNo transaction for request
-901335544364LRequest synchronization error
-901335544365LRequest referenced an unavailable database
-901335544369LAttempted read of a new, open Blob
-901335544370LAttempted action on blob outside transaction
-901335544372LAttempted reference to Blob in unavailable database
-901335544376LTable was omitted from the transaction reserving list
-901335544377LRequest includes a DSRI extension not supported in this implementation
-901335544378LFeature is not supported
-901335544382L
-901335544383LUnrecoverable conflict with limbo transaction
-901335544392LInternal error
-901335544407LDatabase handle not zero
-901335544408LTransaction handle not zero
-901335544418LTransaction in limbo
-901335544419LTransaction not in limbo
-901335544420LTransaction outstanding
-901335544428LUndefined message number
-901335544431LBlocking signal has been received
-901335544442LDatabase system cannot read argument
-901335544443LDatabase system cannot write argument
-901335544450L
-901335544468LTransaction is
-901335544485LInvalid statement handle
-901335544510LLock time-out on wait transaction
-901335544559LInvalid service handle
-901335544561LWrong version of service parameter block
-901335544562LUnrecognized service parameter block
-901335544563LService is not defined
-901335544609LINDEX
-901335544610LEXCEPTION
-901335544611LColumn
-901335544613LUnion not supported
-901335544614LUnsupported DSQL construct
-901335544623LIllegal use of keyword VALUE
-901335544626LTable
-901335544627LProcedure
-901335544641LSpecified domain or source column does not exist
-901335544656LVariable conflicts with parameter in same procedure
-901335544666LServer version too old to support all CREATE DATABASE options
-901335544673LCannot delete
-901335544675LSort error
-902335544333LInternal isc software consistency check ()
-902335544335LDatabase file appears corrupt ()
-902335544344L“I/O error during """" operation tortile """""
-902335544346LCorrupt system table
-902335544373LOperating system directive failed
-902335544384LInternal error
-902335544385LInternal error
-902335544387LInternal error
-902335544388LBlock size exceeds implementation restriction
-902335544394LIncompatible version of on-disk structure
-902335544397LInternal error
-902335544398LInternal error
-902335544399LInternal error
-902335544400LInternal error
-902335544401LInternal error
-902335544402LInternal error
-902335544404LDatabase corrupted
-902335544405LChecksum error on database page
-902335544406LIndex is broken
-902335544409LTransaction-request mismatch (synchronization error)
-902335544410LBad handle count
-902335544411LWrong version of transaction parameter block
-902335544412LUnsupported BLR version (expected , encountered )
-902335544413LWrong version of database parameter block
-902335544415LDatabase corrupted
-902335544416LInternal error
-902335544417LInternal error
-902335544422LInternal error
-902335544423LInternal error
-902335544432LLock manager error
-902335544436LSQL error code =
-902335544448L
-902335544449L
-902335544470LCache buffer for page invalid
-902335544471LThere is no index in table with id
-902335544472LYour user name and password are not defined. Ask your database administrator to set up an InterBase login.
-902335544478LEnable journal for database before starting online dump
-902335544479LOnline dump failure. Retry dump
-902335544480LAn online dump is already in progress
-902335544481LNo more disk/tape space. Cannot continue online dump
-902335544483LMaximum number of online dump files that can be specified is 16
-902335544506LDatabase shutdown in progress
-902335544520LLong-term journaling already enabled
-902335544528LDatabase shutdown
-902335544557LDatabase shutdown unsuccessfuL
-902335544653LCannot attach to password database
-902335544654LCannot start transaction for password database
-902335544564LLong-term joumaling not enabled
-902335544569LDynamic SQL Error
-904335544324LInvalid database handle (no active connection)
-904335544375LUnavailable database
-904335544381LImplementation limit exceeded
-904335544386LToo many requests
-904335544389LBuffer exhausted
-904335544391LBuffer in use
-904335544393LRequest in use
-904335544424LNo lock manager available
-904335544430LUnable to allocate memory from operating system
-904335544451LUpdate conflicts with concurrent update
-904335544453LObject is in use
-904335544455LCannot attach active shadow file
-904335544460LA file in manual shadow is unavailable
-904335544661LCannot add index, index root page is full.
-904335544676LSort error: not enough memory
-904335544683LRequest depth exceeded. (Recursive definition?)
-906335544452LProduct is not licensed
-909335544667LDrop database completed with errors
-911335544459LRecord from transaction is stuck in limbo
-913335544336LDeadlock
-922335544323LFile is not a valid database
-923335544421LConnection rejected by remote interface
-923335544461LSecondary server attachments cannot validate databases
-923335544462LSecondary server attachments cannot start joumaling
-924335544325LBad parameters on attach or create database
-924335544441LDatabase detach completed with errors
-924335544648LConnection lost to pipe server
-926335544447LNo rollback performed
-999335544689LInterBase error

Пример

См. также

GDSCODE, SQLCODE, WHEN, EXCEPTION, Обработка ошибок

Источник

Language Reference 56

Обсуждение